RIPv2

Cofiguring RIPv2

 

Static NAT

 

 

 

 

 

 

 

 

 

 

 

Using the same topology clear off all dynamic and static mappings., stati route, default routes,
GATEWAY(config)#no access-list 1 permit 172.16.0.0 0.0.0.255
GATEWAY(config)#no ip route 0.0.0.0 0.0.0.0 198.0.1.5
GATEWAY(config)#no ip nat inside source static 172.16.0.15 200.20.20.1
GATEWAY(config)#no ip nat inside source list 1 pool STUDYLABS
GATEWAY(config)#no ip nat inside source static 172.16.0.15 200.20.20.1
no ip nat pool STUDYLABS 200.20.20.10 200.20.20.30 netmask 255.255.255.224

current config rid of all stati and default routes

GATEWAY(config)#do sh run
Building configuration…

Current configuration : 788 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname GATEWAY
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
enable password cisco
!
!
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
description EXTERNAL Connection to ISP
ip address 198.0.1.6 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
line con 0
exec-timeout 0 0
password cisco
line vty 0 4
password cisco 123
login
!
!
!
End
Do same on ISP router by clearing the ip route 200.20.20.0 255.255.255.224 198.0.1.6 line in the running config.

We shall be using dynamic routing to forward packets. The new version of RIP is RIPng . for the purpose of this exercise we shall use RIPv2 which is the recommended CCENT level.

We verify that all static routes have been cleared off by pinging from PC to the the ISP. We get time out messages
PC>ping 198.0.1.5

Pinging 198.0.1.5 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.

Ping statistics for 198.0.1.5:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Configure RIPv2 on GW Router

GATEWAY(config)# router rip
GATEWAY(config-router)#ver 2
GATEWAY(config-router)#network 172.16.0.0
GATEWAY(config-router)#network 198.0.1.4
GATEWAY(config-router)#end

Configure RIPv2 on the ISP Router

ISP(config)#router rip
ISP(config-router)#ver 2
ISP(config-router)#network 198.0.1.4
ISP(config-router)#network 10.10.10.0 ( for the loopback)
ISP(config-router)#end

Lets see for what networks RIP will be routing by using the sh ip protocol command

sh ip pro
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 6 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Serial0/0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
198.0.1.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
198.0.1.5 120 00:00:19
Distance: (default is 120)

Basically, Rip send updates every 30 second to listen if it’s neighbour is still online. If the neighbour is down for whatever reason RIP will keep the routing information maintained on it’s Routing Table for another 180s to see if it’s peer comes back online. If so it continues sending updates and go back to normal. If no, it flushes the table after 240 second. This makes RIP a slow protocol.
It is routing on fa0/0 and s0/0/0.
Version is 2
Routing for two networks: 172.16.0.0 and 198.0.1.0
It’s Gateway or next hop is 198.0.1.5 on ISP Router.
It’s Administrative Distance is 120

A ping from PC to ISP is now ok

PC>ping 198.0.1.5

Pinging 198.0.1.5 with 32 bytes of data:

Reply from 198.0.1.5: bytes=32 time=94ms TTL=254
Reply from 198.0.1.5: bytes=32 time=93ms TTL=254
Reply from 198.0.1.5: bytes=32 time=94ms TTL=254
Reply from 198.0.1.5: bytes=32 time=94ms TTL=254

Ping statistics for 198.0.1.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 93ms, Maximum = 94ms, Average = 93ms

PC>ping 10.10.10.1

Pinging 10.10.10.1 with 32 bytes of data:

Reply from 10.10.10.1: bytes=32 time=78ms TTL=254
Reply from 10.10.10.1: bytes=32 time=78ms TTL=254
Reply from 10.10.10.1: bytes=32 time=78ms TTL=254
Reply from 10.10.10.1: bytes=32 time=94ms TTL=254

Ping statistics for 10.10.10.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
GATEWAY#sh ip rip database
10.0.0.0/8 auto-summary
10.0.0.0/8
[1] via 198.0.1.5, 00:00:09, Serial0/0/0
172.16.0.0/24 auto-summary
172.16.0.0/24 directly connected, FastEthernet0/0
198.0.1.4/30 auto-summary
198.0.1.4/30 directly connected, Serial0/0/0

The GW router learned about network 10.0.0.0 /8 via 198.0.1.5 (ISP) on s0/0/0 of it’s own interface.

Issuing the debug ip rip command show how rip handles updates
GATEWAY#debug ip rip
RIP protocol debugging is on
GATEWAY#RIP: received v2 update from 198.0.1.5 on Serial0/0/0
10.0.0.0/8 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
198.0.1.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (198.0.1.6)
RIP: build update entries
172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
RIP: received v2 update from 198.0.1.5 on Serial0/0/0
10.0.0.0/8 via 0.0.0.0 in 1 hops

The Routing table with sh ip route
GATEWAY#sh ip route

R 10.0.0.0/8 [120/1] via 198.0.1.5, 00:00:17, Serial0/0/0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
198.0.1.0/30 is subnetted, 1 subnets
C 198.0.1.4 is directly connected, Serial0/0/0
R means the route is learned via RIP

C means directly connected.

I shutdown int s0/0/1 of the ISP router.. Rip is sending via its multicast ip address but not receiving any updates from neighbour router.
The routing table has been flushed . as shown below.

LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 16, tag 0
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 16, tag 0
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 16, tag 0
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 16, tag 0

GATEWAY#sh ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Find me on YouTube

Recent Posts

Recent Comments