C827 Test Lab Config

C827 ADSL test lab with NAT via SDM
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host
Router(config)#hostname ADSL_router
ADSL_router(config)#hostname ADSL_Router
ADSL_Router(config)#int vlan 1
ADSL_Router(config-if)#ip add
ADSL_Router(config-if)#ip address 10.10.10.1 255.255.255.0
ADSL_Router(config-if)#no shut
ADSL_Router(config-if)#exit
ADSL_Router(config)#ip dhc
ADSL_Router(config)#ip dhcp pool ATTIC
ADSL_Router(dhcp-config)#ipm
ADSL_Router(dhcp-config)#imp
ADSL_Router(dhcp-config)#import ?
all all DHCP options

ADSL_Router(dhcp-config)#import all
ADSL_Router(dhcp-config)#netw
ADSL_Router(dhcp-config)#network 10.10.10.0 255.255.255
% Incomplete command.

ADSL_Router(dhcp-config)#network 10.10.10.0 255.255.255.0
ADSL_Router(dhcp-config)#def rou
ADSL_Router(dhcp-config)#def
ADSL_Router(dhcp-config)#default-router 10.10.10.1
ADSL_Router(dhcp-config)#exit
ADSL_Router(config)#ip dh
ADSL_Router(config)#ip dhcp exc
ADSL_Router(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.10
ADSL_Router(config)#int atm0
ADSL_Router(config-if)#no ip add
ADSL_Router(config-if)#no ip address
ADSL_Router(config-if)#no at
ADSL_Router(config-if)#no atm k
ADSL_Router(config-if)#no atm i
ADSL_Router(config-if)#no atm ilmi-k
ADSL_Router(config-if)#no atm ilmi-keepalive
ADSL_Router(config-if)#pro
ADSL_Router(config-if)#prot
ADSL_Router(config-if)#pvc 8/35
ADSL_Router(config-if-atm-vc)#pro
ADSL_Router(config-if-atm-vc)#protocol ppp dia
ADSL_Router(config-if-atm-vc)#protocol ppp dialer
ADSL_Router(config-if-atm-vc)#dia
ADSL_Router(config-if-atm-vc)#dialer po
ADSL_Router(config-if-atm-vc)#dialer pool-member 1
ADSL_Router(config-if-atm-vc)#dsl

ADSL_Router(config-if)#dsl operating-mode auto
ADSL_Router(config-if)#int
ADSL_Router(config-if)#exit
ADSL_Router(config)#int vlan1
ADSL_Router(config-if)#ip nat in
ADSL_Router(config-if)#ip nat inside
%NAT: Error activating CNBAR on the interface Vlan1
ADSL_Router(config-if)#
*Mar 2 03:56:54.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan
ged state to up
ADSL_Router(config-if)#ip nat inside
ADSL_Router(config-if)#spee
ADSL_Router(config-if)#speed ?
% Unrecognized command
ADSL_Router(config-if)#exit
ADSL_Router(config)#int dia
ADSL_Router(config)#int dialer 1
ADSL_Router(config-if)#ip add
ADSL_Router(config-if)#ip address neg
ADSL_Router(config-if)#ip address negotiated
ADSL_Router(config-if)#ip mtu 1492
ADSL_Router(config-if)#ip nat ou
ADSL_Router(config-if)#ip nat outside
%NAT: Error activating CNBAR on the interface Dialer1
ADSL_Router(config-if)#ip nat outside
%NAT: Error activating CNBAR on the interface Dialer1
ADSL_Router(config-if)#enc
ADSL_Router(config-if)#encapsulation ppp
ADSL_Router(config-if)#ip tcp ad
ADSL_Router(config-if)#ip tcp adjust-mss 1452
ADSL_Router(config-if)#dial
ADSL_Router(config-if)#dialer po
ADSL_Router(config-if)#dialer pool 1
ADSL_Router(config-if)#
*Mar 2 03:59:08.815: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
o up
*Mar 2 03:59:09.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Ac
cess1, changed state to up
ADSL_Router(config-if)#
ADSL_Router(config-if)#ip nat outside
%NAT: Error activating CNBAR on the interface Dialer1
ADSL_Router(config-if)#dial
ADSL_Router(config-if)#dialer gr
ADSL_Router(config-if)#dialer-g
ADSL_Router(config-if)#dialer-group 1
ADSL_Router(config-if)#ppp auth
ADSL_Router(config-if)#exit
ADSL_Router(config)#ppp auth
ADSL_Router(config)#ppp ?
limit Set the limit

ADSL_Router(config)#int dialer 1

————————————————————————————————
complete config.
————————————————————————————–

ADSL_Router#sh run
*Mar 2 04:31:17.447: %SYS-5-CONFIG_I: Configured from console by console
Building configuration…

Current configuration : 1560 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ADSL_Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool ATTIC
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
!
ip cef
!
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/35
dialer pool-member 1
protocol ppp dialer
!
pvc 8/35
dialer pool-member 1
protocol ppp dialer
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname ******@*********
ppp chap password 7 02145D775C3F012018
ppp chap password 7 02145D775C3F012018
ppp ipcp dns request
ppp ipcp wins request
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

ADSL_Router#

DSL_Router#sh ip int bri
Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

ATM0 unassigned YES manual up up

Vlan1 10.10.10.1 YES manual up up

NVI0 unassigned NO unset up up

Dialer1 213.49.113.16 YES IPCP up up

Virtual-Access1 unassigned YES unset up up

Virtual-Access2 unassigned YES unset up up

Virtual-Access3 unassigned YES unset up dow

ADSL_Router# sh ip nat tra
ADSL_Router# sh ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 213.49.113.16:49425 10.10.10.11:49425 66.77.197.182:80 66.77.197.182:80
tcp 213.49.113.16:49427 10.10.10.11:49427 209.85.229.99:80 209.85.229.99:80
tcp 213.49.113.16:49435 10.10.10.11:49435 209.85.227.104:80 209.85.227.104:80
tcp 213.49.113.16:49441 10.10.10.11:49441 209.85.227.113:80 209.85.227.113:80
tcp 213.49.113.16:49451 10.10.10.11:49451 74.125.77.102:80 74.125.77.102:80
udp 213.49.113.16:53986 10.10.10.11:53986 193.74.208.65:53 193.74.208.65:53
udp 213.49.113.16:54350 10.10.10.11:54350 10.0.2.15:161 10.0.2.15:161
ADSL_Router#sh ip access-lists
Extended IP access list 102
10 permit ip 10.10.10.0 0.0.0.255 any (41 matches)

DSL_Router# sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Vlan1
213.49.113.0/32 is subnetted, 2 subnets
C 213.49.113.16 is directly connected, Dialer1
C 213.49.113.1 is directly connected, Dialer1
S* 0.0.0.0/0 is directly connected, Dialer1

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Find me on YouTube

Recent Posts

Recent Comments